php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3852 mysql_pconnect sometimes works when it isn't supposed to.
Submitted: 2000-03-16 17:30 UTC Modified: 2005-03-31 16:13 UTC
From: truth at ichaos dot com Assigned: georg (profile)
Status: Wont fix Package: MySQL related
PHP Version: 3.0.15 OS: Linux 2.2.13
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
20 - 17 = ?
Subscribe to this entry?

 
 [2000-03-16 17:30 UTC] truth at ichaos dot com
I am using MySQL version 3.22.30.

I have a PHP3 program that check the return of a mysql_pconnect() command to see if it successfully connected as a user that does not exist. Half of the time, it returns false as it should and reports a warning that the user could not connect. The other half it returns true, or not false, and gives no warnings, even though it really didn't connect at all.

Changing my code to use mysql_connect() instead works.

I've tried under older versions of both PHP3 (3.0.12) and MySQL (3.22.27) and it  works just fine.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-31 16:13 UTC] php-bugs at lists dot php dot net
We are sorry, but we do not support PHP 3 related problems anymore.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Aug 14 00:05:44 2022 UTC