php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38459 tidy and mysqli memory errors
Submitted: 2006-08-15 02:37 UTC Modified: 2006-08-15 08:11 UTC
From: info at tcknetwork dot com Assigned:
Status: Closed Package: Tidy (PECL)
PHP Version: 5.1.4 OS: Windows XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: info at tcknetwork dot com
New email:
PHP Version: OS:

 

 [2006-08-15 02:37 UTC] info at tcknetwork dot com
Description:
------------
When mysqli or/and tidy extensions are loaded, they produce a memory error and make the server (Apache 2.2.2) crashes.

So far I know these problems should have been introduced in the 5.1.3 or 5.1.4 because i ran long with 5.1.2 without noticing any of those problems.

Reproduce code:
---------------
<?
// only one test is necessary
// test 1
function test() { test(); }
test();

// test 2
class a {
 function test() { $this->test(); }
};
$a=new a();
$a->test();
?>

Expected result:
----------------
Without those extensions loaded, you get a blank file to download, which is the correct result.

Actual result:
--------------
With one or both of those extensions loaded, you get a crash of the server, even when using none of the extension's functionality (see the code above).

Another complete crash appears in the export function of phpMyAdmin (export a table in sql for example), I didn't parsed that code for the moment, but it appears even with only mysql (not i) extension loaded.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-15 06:42 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip


 [2006-08-15 08:11 UTC] info at tcknetwork dot com
with the snapshot php5.2.0.0 for win32 (2006-08-14 22:30)
and using the new apache hooks for 2.2 version, this issue has been solved. But the bug in phpMyAdmin still remain (memory error, but the server doesn't crash anymore)... I'll open a new report if i find the root of this error.
Thank you.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 28 06:03:41 2022 UTC