php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #38442 Install instructions FastCGI
Submitted: 2006-08-13 12:44 UTC Modified: 2012-11-12 02:23 UTC
Votes:5
Avg. Score:4.4 ± 0.8
Reproduced:2 of 4 (50.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: holliwell at gmx dot net Assigned:
Status: Wont fix Package: Documentation problem
PHP Version: Irrelevant OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: holliwell at gmx dot net
New email:
PHP Version: OS:

 

 [2006-08-13 12:44 UTC] holliwell at gmx dot net
Description:
------------
Hey,
the docs are missing install instructions for the FastCGI sapi. 

Regards
Friedhelm


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-06-15 15:31 UTC] philip@php.net
Alex is working on this
 [2007-06-15 16:36 UTC] asonge@php.net
Acknowledged
 [2008-04-11 18:40 UTC] asonge@php.net
Fixed in CVS
 [2008-04-14 11:29 UTC] holliwell at gmx dot net
Hi,
thanks for the fix.
http://docs.php.net/ is always up to date, however I didn't find anything about FastCGI Sapi.

Care to give me a link (online on docs.php.net or cvs.php.net)?
Thx
Friedhelm
 [2008-04-14 13:07 UTC] holliwell at gmx dot net
Hm,
I have to disagree that this bug is fixed.
Not ownly lighttpd is able to use FastCGI;-)

We have also Apache on various plattforms and IIS with FastCGI?
In the Docs we explain how to setup webservers with mod_php, isapi, cgi, etc.
In this context, we have no instructions execpt lighttpd.
Thanks
Friedhelm
 [2009-12-14 14:26 UTC] rbowen at rcbowen dot com
I've added mod_fcgid docs to the Apache/Windows install doc, and will be 
adding the comparable version to the Unix doc within the next week or 
so. Meanwhile, you can look at the Windows version and make the relevant 
path changes to get it to work for Unix.

mod_fcgid is now the recommended FastCGI implementation for Apache 2.x. 
I don't know, yet, what one is supposed to do for Apache 1.3, since I've 
never run fastcgi on 1.3, and don't intend to, now that we're in the 
21st century. :)
 [2010-01-07 11:49 UTC] kalle@php.net
Rich, for references, then FastCGI w/IIS is documented here:
http://php.net/install.windows.iis7
http://php.net/install.windows.iis6

As for FastCGI on 1.3, I think it would be bad to document information that would be *useless* or hacky in the end, so perhaps we should just leave that out.
 [2010-10-24 15:49 UTC] olafvdspek at gmail dot com
> and will be adding the comparable version to the Unix doc within the next week or so.

What happened?
 [2010-10-25 15:20 UTC] rbowen@php.net
Hard to say what happened. I think I'll go with "life got in the way", which I 
suppose means that I'm blaming my kids. :)

I'll try to get this knocked out while at ApacheCon next week, but if I don't, I 
might end up relinquishing ownership of this issue so that someone else can take a 
whack at it.
 [2010-12-27 20:04 UTC] rbowen@php.net
-Status: Assigned +Status: Open -Assigned To: rbowen +Assigned To:
 [2012-01-07 19:06 UTC] frozenfire@php.net
FastCGI has long been bundled with PHP, to the effect that no versions in their 
maintenance cycle still require it be installed manually. In fact, using regular 
CGI requires special effort.

I do not believe that documentation for FastCGI is warranted, much less required.

If there are no objections, I'm going to close this bug as wont-fix.
 [2012-01-08 00:04 UTC] olafvdspek at gmail dot com
> I do not believe that documentation for FastCGI is warranted, much less 
required.

AFAIK FastCGI is the best way to use PHP. Why do you think it deserves no 
documentation?
 [2012-01-14 05:21 UTC] frozenfire@php.net
I didn't mean that FastCGI should go undocumented. I just don't see the point in 
providing install instructions for a component of PHP that has long been bundled, 
and could even be considered intrinsic.
 [2012-01-14 08:51 UTC] olafvdspek at Gmail dot com
I think it's about the webserver-side installation and about setting PHP FPM via an init script etc.
 [2012-11-12 02:23 UTC] aharvey@php.net
I'm going to close this on the grounds that it's too vague to really write anything for — specific suggestions for improving the FPM documentation, in particular, would be welcome, but I don't think this is the bug to cover that.
 [2012-11-12 02:23 UTC] aharvey@php.net
-Status: Open +Status: Wont fix
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Apr 17 01:01:29 2024 UTC