php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38421 Bug #37265 not completely fixed
Submitted: 2006-08-11 09:59 UTC Modified: 2006-08-11 15:09 UTC
From: mmarek at suse dot cz Assigned: iliaa (profile)
Status: Closed Package: IMAP related
PHP Version: 5CVS-2006-08-11 (CVS) OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mmarek at suse dot cz
New email:
PHP Version: OS:

 

 [2006-08-11 09:59 UTC] mmarek at suse dot cz
Description:
------------
I can't add a comment to bug #37265 (why??) so I've to post here: The bug is still not fixed, because imap_reopen() needs the same check too.



Reproduce code:
---------------
$mbox = imap_open("/path/to/allowed/file", "", "");
imap_reopen($mbox, "/path/to/arbitrary/file");
$file = imap_body($mbox, 1);
echo $file;


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-11 15:09 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 21 21:03:37 2022 UTC