php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3836 When rawurlencoded, this character: ' causes problems
Submitted: 2000-03-15 09:22 UTC Modified: 2002-09-30 17:47 UTC
From: shr at dmi dot dk Assigned:
Status: Not a bug Package: Reproducible Crash
PHP Version: 3.0.12 OS: UNIX
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
34 - 34 = ?
Subscribe to this entry?

 
 [2000-03-15 09:22 UTC] shr at dmi dot dk
When rawurlencodeing this character ' 
three \\\ are inserted each time the 
encodeing is performed. And this adds
up since the \ is coded too. It can cause
a crash fairly quickly when encoding is done
a lot.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-03-20 07:29 UTC] shr at dmi dot dk
I was wrong! It is not the rawurlencode that causes the problem.
But somehow a variable containing a ' character encoded as %27 on the Location
line is reproduced as \' .
I don't know why!?
 [2002-09-30 17:47 UTC] hholzgra@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.

hint: magic_quotes settings ...
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jul 10 01:01:27 2020 UTC