|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38358 unable to set uid
Submitted: 2006-08-06 15:38 UTC Modified: 2006-08-30 07:10 UTC
From: totooo_hegab at yahoo dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.4.3 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: totooo_hegab at yahoo dot com
New email:
PHP Version: OS:


 [2006-08-06 15:38 UTC] totooo_hegab at yahoo dot com
i am trying to execute a command, i used "exec" and "system" and ` ` functions they worked well for example exec("ls",$var) and echo system("ls") 

when i tried to execute the following command 

exec("/home/vpopmail/vuserinfo user@domain",$var)

the following appears: "unable to set uid"

note that:
The appache2 web server runs as "vpopmail" user
vuserinfo: used to return details about user@domain
the permissions of the script vuserinfo is: 751
the ownership of the script vuserinfo is: vpopmail
the group of the script vuserinfo is: vchkpw


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-06 15:53 UTC]
What OS do you use and why do you think it's PHP issue?
 [2006-08-06 15:56 UTC] totooo_hegab at yahoo dot com
the server runs at linux

i tried all the probabilities, so i think it is from php
 [2006-08-06 16:43 UTC]
Did you try to login as vpopmail user and run this command in console?
 [2006-08-07 06:52 UTC] totooo_hegab at yahoo dot com
yes the command works will on the console

what will i do then?!!
 [2006-08-29 21:21 UTC]
What is the exact output you get with
var_dump(exec("/home/vpopmail/vuserinfo user@domain", $var));
 [2006-08-30 06:40 UTC] totooo_hegab at yahoo dot com
thank u for ur care, the error was not from the php as u said before

the error was from passing the arguments to vuserinfo
 [2006-08-30 07:10 UTC]
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Feb 25 11:01:27 2024 UTC