php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38177 php CLI crashes if sybase_ct extension is enabled
Submitted: 2006-07-21 15:38 UTC Modified: 2006-07-26 23:46 UTC
From: francesco dot marsan at yahoo dot it Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 5.1.4 OS: Windows 2003 Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: francesco dot marsan at yahoo dot it
New email:
PHP Version: OS:

 

 [2006-07-21 15:38 UTC] francesco dot marsan at yahoo dot it
Description:
------------
php 5.1.4 ran as CLI (php.exe) crashes if php_sybase_ct.dll is enabled. The script actually gives correct results, but at the same time (should be after the script is finished, actually...) php crashes.

Tried a current snapshot but couldn't find the php_sybase_ct.dll extension there, and the one available from pecl won't compile because of the different API number.

Reproduce code:
---------------
php.exe -v 
(yes, just this is enough)

Expected result:
----------------
The output is actually correct, but a segfault happens. 

Actual result:
--------------
The crash is visible in the Event Viewer (Faulting application php.exe, version 5.1.4.4, faulting module unknown, version 0.0.0.0, fault address 0x00e71870.)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-22 15:52 UTC] sniper@php.net
What other extensions you have enabled?
 [2006-07-22 18:07 UTC] francesco dot marsan at yahoo dot it
These two: php_oci8.dll, php_curl.dll
 [2006-07-23 12:42 UTC] sniper@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2006-07-23 13:39 UTC] francesco dot marsan at yahoo dot it
I will see if I can find MSVC to do the backtrace. 
But how am I going to test it if php_sybase_ct.dll is not available neither in the php5.2 distribution on the snaps site nor in the list of 5.1.x extensions from the pecl site?
 [2006-07-24 00:02 UTC] sniper@php.net
Hopefully the next snapshot in about 3 hours is going to contain the extension. (there were some typos in the code :)
 [2006-07-24 00:05 UTC] sniper@php.net
Make that 6 hours.
 [2006-07-26 16:25 UTC] francesco dot marsan at yahoo dot it
I tried installing version 5.2.0RC2-dev from the snaps site and it looks that the problem has gone. So for me we can close this bug.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Mar 08 01:01:24 2021 UTC