php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38164 Contact form - Output Error
Submitted: 2006-07-20 14:45 UTC Modified: 2006-07-20 14:52 UTC
From: ana dot garment at mail dot telepac dot pt Assigned:
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS: Widnows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ana dot garment at mail dot telepac dot pt
New email:
PHP Version: OS:

 

 [2006-07-20 14:45 UTC] ana dot garment at mail dot telepac dot pt
Description:
------------
Dear Sirs,

We are changing our website and included 1 option for contacts made with PHP.
We have published it and we have an Output Erro.

I believe there is a problem with our file, hereby, and sk you kindly to help us or let us know who can help.

Waiting to hear from Y/,
Thanks for Y/ help,
B.Regards
Ana Ferreira
---
www.garmentadvisors.com



Reproduce code:
---------------
<HTML>
<HEAD>
<meta http-equiv=Content-Type content="text/html;  charset=ISO-8859-1">
<TITLE>menu_p</TITLE>
</HEAD>
<?
if(!empty($_POST['sender_mail']) || !empty($_POST['sender_message']) || !empty($_POST['sender_subject']) || !empty($_POST['sender_name']))

{

$to = "garment@mail.telepac.pt"; 
$s_name = $_POST['sender_name'];
$s_mail = $_POST['sender_mail'];
$subject = stripslashes($_POST['sender_subject']);
$body = stripslashes($_POST['sender_message']);
$body .= "\n\n---------------------------\n";
$body .= "Mail enviado por: $s_name <$s_mail>\n";
$header = "From: $s_name <$s_mail>\n";    
$header .= "Reply-To: $s_name <$s_mail>\n"; 
$header .= "X-Mailer: PHP/" . phpversion() . "\n";
$header .= "X-Priority: 1";

	if(@mail($to, $subject, $body, $header))
	{
		echo "output=sent";
	} else {        
		echo "output=error";    
	}


}else {    
	echo "output=error";

}


?>
<BODY bgcolor="#FFFFFF" topmargin="0" leftmargin="0">
<table border="0" width="100%" height="100%" cellpading="0" cellspacing="0">
	<tr>
		<th><!-- URL's used in the movie-->
<!-- text used in the movie-->
<!--menu--><OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
 codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0"
 WIDTH="835" HEIGHT="627" id="menu_p" ALIGN="">
 <PARAM NAME=movie VALUE="menu_p.swf"> <PARAM NAME=quality VALUE=high> <PARAM NAME=bgcolor VALUE=#FFFFFF> <EMBED src="menu_p.swf" quality=high bgcolor=#FFFFFF  WIDTH="835" HEIGHT="627" NAME="menu_p" ALIGN=""
 TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED>
</OBJECT></th>
	</tr>
</table>
</BODY>
</HTML>

Expected result:
----------------
We excpect that contact database is sent directly to our email adress (garment@mail.telepac.pt)

Actual result:
--------------
output=error

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-20 14:52 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 00:05:44 2022 UTC