php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38101 Undefinded Variable NO ERROR MESSAGE!!
Submitted: 2006-07-14 07:01 UTC Modified: 2006-07-14 07:37 UTC
From: nimce4u at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: * OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nimce4u at gmail dot com
New email:
PHP Version: OS:

 

 [2006-07-14 07:01 UTC] nimce4u at gmail dot com
Description:
------------
When I print a variable who I DIDN'T defind before I DON'T get an error!!!

It will help me if I'll get an error when I didn't defind a variable and then wanted it's value...
Thank you!

Reproduce code:
---------------
<?php
print $var;
?>

Expected result:
----------------
WARNING/ERROR because I didn't defind this variable...

Actual result:
--------------
Nothing...
It printed nothing!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-14 07:37 UTC] helly@php.net
marcus@zaphod /usr/src/php-cvs $ php -r 'print $x;'
make: `sapi/cli/php' is up to date.

Notice: Undefined variable: x in Command line code on line 1
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 15 16:05:46 2022 UTC