php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37897 Code error
Submitted: 2006-06-23 00:06 UTC Modified: 2006-06-23 07:55 UTC
From: demonhunterds at hotmail dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 5.1.4 OS: windows xp
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: demonhunterds at hotmail dot com
New email:
PHP Version: OS:

 

 [2006-06-23 00:06 UTC] demonhunterds at hotmail dot com
Description:
------------
I have tried to create a script which stores data in to the mysql database but for some reason i am getting this error

Fatal error: Method name must be a string in D:\william\xampp\htdocs\personal\classwork\EXAMPLE2\admin\includes\addmenu.inc on line 28

I have tried to research and thought this might be a problem how can i fix this?

Reproduce code:
---------------
The Changes i have made are by removing it but still doesnt insert the data into the database so how can i fix this? any ideas how this can be fixed?

include("../dbconnect.php");
$lQuery="INSERT INTO navmenu VALUES('','".$lname."','".$laddy."')";
echo $lQuery;

and under it i have 

if(!$rs)
{
echo "Error:".mysqli_error($con);
}

Expected result:
----------------
i got the error when i click my submit button and didnt do anything i tried to do echo iquery that worked fine but without me going into the database it doesnt do anything.

Actual result:
--------------
it is suppose to insert the data into the table called navmenu but doesnt do that unless i use the sql query so how can i fix this? if i do put the insert code it works just gives me that error

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-06-23 07:55 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 22 04:01:31 2024 UTC