php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37631 Strange files on root directory.
Submitted: 2006-05-29 18:05 UTC Modified: 2006-05-29 19:50 UTC
From: paes at abaco dot com dot br Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.1.4 OS: Linux 2.4.32
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: paes at abaco dot com dot br
New email:
PHP Version: OS:

 

 [2006-05-29 18:05 UTC] paes at abaco dot com dot br
Description:
------------
When I disable "expose_php", PHP create some files on root directory.
I'm running Apache 1.3.36 and mod_SSL 2.8.27.

Expected result:
----------------
None of these files on root directory.

Actual result:
--------------
expose_php = Off in /var/www/conf/php.ini

# apachectl stop && apachectl startssl
# ls -la /
..
-rw-r--r--  1 root root 67584 2006-05-29 13:53 .3.36 (Unix)
-rw-r--r--  1 root root     1 2006-05-29 13:53 .3.36 (Unix).lock
..
(Note: I'm running Apache under user www)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-29 18:13 UTC] tony2001@php.net
What makes you think it's PHP creates them (expecially when it's running under www user)?
 [2006-05-29 18:26 UTC] paes at abaco dot com dot br
# grep ^expose_php /var/www/conf/php.ini
expose_php = On
# apachectl startssl
/usr/sbin/apachectl startssl: httpd started
# ls -la / | grep .3.36
<no result>

And when I change the value of expose_php on php.ini:
# grep ^expose_php /var/www/conf/php.ini
expose_php = Off
# apachectl startssl
/usr/sbin/apachectl startssl: httpd started
# ls -la / | grep .3.36
-rw-r--r--  1 root root 67584 2006-05-29 14:16 .3.36 (Unix)
-rw-r--r--  1 root root     1 2006-05-29 14:16 .3.36 (Unix).lock

Not necessary under user www, just a comment because the file ownership is not www.
 [2006-05-29 19:14 UTC] tony2001@php.net
Obviously some software in your system does this.
Just a hint: the ".3.36 (Unix)" part of the name looks like the line from "Server" header, which expose_php changes from "Server: Apache/1.3.36 (Unix)" to "Server: Apache/1.3.36 (Unix) PHP/<server>".
This is the only thing expose_php changes.
 [2006-05-29 19:50 UTC] paes at abaco dot com dot br
But I was tried to compile PHP only with: ./configure --prefix=/usr --with-apxs=/usr/sbin/apxs and I got the same error..

Another thing is that files appears only when I start with "startssl".. Maybe a mod_SSL problem so?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Sep 27 15:05:53 2022 UTC