php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37609 URL parsing problem with query string and anchor in IE
Submitted: 2006-05-26 23:43 UTC Modified: 2006-05-27 09:36 UTC
From: dmb27 at cornell dot edu Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 5.1.4 OS: Debian unstable 2.6.15 kernel
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dmb27 at cornell dot edu
New email:
PHP Version: OS:

 

 [2006-05-26 23:43 UTC] dmb27 at cornell dot edu
Description:
------------
This is basically bug #9699, but it is marked as closed, and I can't comment on it, and it still exists in PHP 5.1.2

A redirect to a URL with both a query string and an anchor reference treats the anchor portion as part of the query string.

For example, in my application, using IE 6, a redirect to:
http://adventurersguild.wikispaces.com/message/view/Trading+Board/23190?o=0#28590
has a [QUERY_STRING] => o=0#28590
however in Firefox, [QUERY_STRING] => o=0

If I hit refresh at the error, it doesn't do a redirect and everything is fine.

This happens only in Internet Explorer 6, not in Firefox 1.5.0.3


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-27 09:36 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Oct 23 08:03:33 2021 UTC