php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37432 Warning message 'Remember to run libtool --finish' during 'make install'.
Submitted: 2006-05-14 02:03 UTC Modified: 2006-07-19 14:33 UTC
Votes:8
Avg. Score:3.1 ± 1.5
Reproduced:7 of 8 (87.5%)
Same Version:1 (14.3%)
Same OS:2 (28.6%)
From: support at positrondata dot com Assigned:
Status: Wont fix Package: Compile Warning
PHP Version: 5.1.4 OS: Fedora Core 5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: support at positrondata dot com
New email:
PHP Version: OS:

 

 [2006-05-14 02:03 UTC] support at positrondata dot com
Description:
------------
When I run 'make install' with PHP 5.1.4, Apache 2.2.2 and MySQL 5.0.19 I get a warning message that reads

libtool: install : warning: 'remember to run libtool --finish  
/home/tkelly/Desktop/php-5.1.4/libs.

Do I need to run this if it is just a warning?  All seems to be working OK but this message gives me an insecure feeling.  I also wonder why the 'make install' cannot run this since it seems to be just another command.  I've gotten this message with other PHP, Apache, MySQL configurations that I've downloaded and recompiled so it does not seem to be specific to one build environment.  I've also looked at the libtool documentation but that doesn't say what the libtool --finish actually does internally to the libraries. 

Is my environment somehow incomplete for 'make install'? The 'make' used an absolute path to the home/tkelly/Desktop/php-5.1.4/libtool so I am presuming 'make install' can also find this same version of libtool. Tom Kelly.

Reproduce code:
---------------
N/A

Expected result:
----------------
N/A

Actual result:
--------------
N/A

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-19 14:33 UTC] sniper@php.net
You can safely ignore it. 
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Aug 14 06:04:06 2022 UTC