php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37390 mnoGoSearch completely disappeared
Submitted: 2006-05-09 22:51 UTC Modified: 2006-05-10 00:39 UTC
From: wasti dot redl at gmx dot net Assigned: pajoye (profile)
Status: Not a bug Package: mnoGoSearch related
PHP Version: 5.1.4 OS: Linux Gentoo
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wasti dot redl at gmx dot net
New email:
PHP Version: OS:

 

 [2006-05-09 22:51 UTC] wasti dot redl at gmx dot net
Description:
------------
The documentation of the mnoGoSearch functions contains this notice:
"Note:  This extension has been moved to the PECL repository and is no longer bundled with PHP as of PHP 5.1.0."

However, there is no mnoGoSearch extension in PECL.

Not only is this highly confusing, it's also a big problem for users of mnoGoSearch. There is absolutely no documentation for the PHP extension downloadable from mnogosearch.org itself, not even a hint that you have to use phpize to install the extension.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-09 23:02 UTC] pajoye@php.net
The problem was that there is no active maintainer. Releasing a package in pecl without having someone to take of it is pointless if not dangerous.

I do maintain it now, at least until someone steps in to help.

About the phpite hint, is this page not clear enough?
http://www.php.net/manual/en/install.pecl.phpize.php

I will release a version as soon as I can. But this is not a bug. Feel free to report bugs again if you have problems with mnogosearch (but not about the releases :)
 [2006-05-09 23:06 UTC] wasti dot redl at gmx dot net
The page may be clear, but it is not exactly reachable.

Consider it a doc problem then: tell the reader that the extension is currently only available from the vendor, perhaps add a few lines about installing it, and when you can finally release a version, change the notice.

The real problem here is that the docs claim that mnoGoSearch is in PECL when it isn't.
 [2006-05-10 00:39 UTC] pajoye@php.net
It is not a doc problem. It is available in pecl, only not as release. And again this is a temporary state

The docs about installing pecl packages is clear, or dp you have some corrections or precisions in mind?
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 31 16:01:27 2021 UTC