php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37359 with-freetype-dir not used for libt1 test
Submitted: 2006-05-08 05:08 UTC Modified: 2006-05-08 21:03 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: john at jcoppens dot com Assigned: pajoye (profile)
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.1.4 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: john at jcoppens dot com
New email:
PHP Version: OS:

 

 [2006-05-08 05:08 UTC] john at jcoppens dot com
Description:
------------
I (tried) to run configure with

--with-freetype-dir=/usr/X11

(among other options, of course). This works fine for libfreetype itself, but the config process stops
on (failing) to detect libt1:
If configure fails try --with-xpm-dir=<DIR>
checking for FreeType 1 support... no - FreeType 2.x is to be used instead
checking for T1_StrError in -lt1... no
configure: error: Problem with libt1.(a|so). Please check config.log for more information.

It says 'no' here, not because t1 doesn't exist, but because it cannot find freetype. From the config.log:

configure:35897: checking for T1_StrError in -lt1                               
configure:35916: gcc -o conftest -g -O2  -Wl,-rpath,/usr/local/lib -L/usr/local/lib  -Wl,-rpath,/opt/gnome/lib -L/opt/gnome/lib conftest.c -lt1  -lfreetype -lpng -lz -lbz2 -lz -lresolv -lm -ldl -lnsl  -lxml2 -lz -lm -lxml2 -lz -lm 1>&5     
/usr/lib/gcc/i686-pc-linux-gnu/3.4.6/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lfreetype                                                               

Probably because the /usr/X11 path is not included.



Expected result:
----------------
I'd expect the path from --with-freetype-dir to be included in all places where it is needed.

Sorry if I'm incorrect here... I'm not an expert programmer.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-08 14:42 UTC] john at jcoppens dot com
I've solved the problem for the moment adding LDFLAGS:

LDFLAGS=-L/usr/X11/lib ./configure --with-mysql=/opt/ ...

but I doubt that is the elegant solution.
 [2006-05-08 14:46 UTC] pajoye@php.net
What's your configure line?

Did you use --with-t1lib-dir?
 [2006-05-08 16:00 UTC] john at jcoppens dot com
Below is the config command. I did not use --with-t1lib-dir for two reasons: 
1) I thought that was for only for t1lib, which is found
2) It's not only a problem compiling t1lib. If I disable
   t1lib in the config, the same problem appears with
   another library (also because of not finding freetype)

LDFLAGS=-L/usr/X11/lib ./configure --with-mysql=/opt/mysql --with-apxs --with-ming --with-zlib --with-bz2 --enable-exif --enable-ftp --with-gd --enable-gd-native-ttf --with-ttf=/usr/X11 --with-freetype-dir=/usr/X11 --enable-sockets --with-t1lib --with-truetype --prefix=/usr --enable-mbstring --with-libxml-dir=/opt/gnome
 [2006-05-08 16:05 UTC] pajoye@php.net
Please use the t1lib directive and run the configure without LD_FLAGS.

"If I disablet1lib in the config, the same problem appears with another library (also because of not finding freetype)"

Can you be more clear? Please paste the exact errors here, and which libraries do not work, for which extensions.
 [2006-05-08 16:24 UTC] john at jcoppens dot com
adding:
--with-t1lib=/usr/local

same error:
checking for FreeType 1 support... no - FreeType 2.x is to be used instead
checking for T1_StrError in -lt1... no
configure: error: Problem with libt1.(a|so). Please check config.log for more information.

The --with-t1lib-dir directive you asked for does not appear in ./configure --help, so I suspect it has to be the above directive (--with-t1lib=...)

Then, disabling --without-t1lib, I get the error:

checking for iconv in -liconv... no
configure: error: Please reinstall the iconv library.

which, again, is not the fault of not finding iconv, but
not finding freetype (according to the config.log):

configure:45338: gcc -o conftest -g -O2   -Wl,-rpath,/opt/gnome/lib -L/opt/gnome
/lib conftest.c -liconv  -lfreetype -lpng -lz -lbz2 -lz -lresolv -lm -ldl -lnsl -lxml2 -lz -lm -lxml2 -lz -lm 1>&5                                             
/usr/lib/gcc/i686-pc-linux-gnu/3.4.6/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lfreetype
 [2006-05-08 21:03 UTC] pajoye@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

"configure: error: Problem with libt1.(a|so). Please check config.log for more information."

Did you install the t1lib develpement package?

"checking for iconv in -liconv... no
configure: error: Please reinstall the iconv library.
which, again, is not the fault of not finding iconv, but
not finding freetype (according to the config.log):"

No, you are missing iconv or the development packages (-devel or whatever it is on your platform).

I do not see something about freetype not found, only that it will use freetype2.

What you pasted here from your config.log is sadly useless. However, it is clear that you did not install everything required to compile PHP. It is not a bug.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Sep 26 12:05:52 2022 UTC