php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37195 IIS5 with PHP 5.1.2 ISAPI not loading DB extentions
Submitted: 2006-04-25 10:03 UTC Modified: 2006-04-25 10:08 UTC
From: Thomas dot Klaver at versatel dot com Assigned:
Status: Not a bug Package: *Database Functions
PHP Version: 5.1.2 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Thomas dot Klaver at versatel dot com
New email:
PHP Version: OS:

 

 [2006-04-25 10:03 UTC] Thomas dot Klaver at versatel dot com
Description:
------------
PHP loaded as ISAPI in IIS5 does not load php_mssql.dll and php_mysql.dll.

After loading PHP as CGI with exactly the same configuration, everything works smoothly.

Another module we use, GD, is loading properly with both ISAPI as CGI.

PHP is not crashing, just not loading the modules.

Reproduce code:
---------------
extension_dir = "ext/"
extension=php_gd2.dll
extension=php_mssql.dll
extension=php_mysql.dll

Expected result:
----------------
Succesful loading of those modules

Actual result:
--------------
php_mysql.dll and php_mssql.dll are not loaded

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-25 10:08 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jul 08 02:01:27 2020 UTC