php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37166 Detected illegal character in input string.
Submitted: 2006-04-22 14:28 UTC Modified: 2006-04-22 14:39 UTC
From: bogdan at directdesign dot ro Assigned:
Status: Not a bug Package: ICONV related
PHP Version: 4.4.2 OS: windows xp & linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bogdan at directdesign dot ro
New email:
PHP Version: OS:

 

 [2006-04-22 14:28 UTC] bogdan at directdesign dot ro
Description:
------------
I cannot decode the cross sign (?) from UTF-8.
The iconv() function stops with a notice and does not parse after this sign.

Reproduce code:
---------------
<?
	error_reporting(E_ALL);
	echo iconv('UTF-8', 'ISO-8859-2', "123 † 456");
?>

Expected result:
----------------
123 ? 456

Actual result:
--------------
Notice: iconv(): Detected illegal character in input string in E:\Inetpub\test\bug-cruce.php on line 3
123 PHP Notice: iconv(): Detected illegal character in input string in E:\Inetpub\test\bug-cruce.php on line 3 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-22 14:39 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 06:03:37 2021 UTC