php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37151 Can't use class::method to call php functions from within XSLT templates
Submitted: 2006-04-20 22:20 UTC Modified: 2006-04-21 05:01 UTC
From: glan at gotsubstance dot co dot uk Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 5.1.2 OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: glan at gotsubstance dot co dot uk
New email:
PHP Version: OS:

 

 [2006-04-20 22:20 UTC] glan at gotsubstance dot co dot uk
Description:
------------
After registerPHPFunctions in XSLT, you can't use the scope 
resolution operator (::) to call a method within a class.

I.e. (this used to work <5.1.2):
"If you wish to use a function from inside a class use the 
double colon (::) notation, for example;

php:functionString('classname::function')

The funtion is fired off as a static and as such acts like a 
function in the global namespace." from [http://fr.php.net/
manual/en/function.xsl-xsltprocessor-register-php-
functions.php] 

This no longer works and will throw the following error 
Unable to call handler classname::function

I'm not sure what the real value of this functionality was 
anyway and have worked around this in my code, but it was 
avalible in previous versions.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-20 22:51 UTC] tony2001@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc.

If possible, make the script source available online and provide
an URL to it here. Try to avoid embedding huge scripts into the report.


 [2006-04-21 05:01 UTC] chregu@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

I assume, this is a duplicate of #37091
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 29 09:02:33 2020 UTC