php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37121 PEAR_CONFIG_DEFAULT_PHP_DIR misdefined?
Submitted: 2006-04-18 17:21 UTC Modified: 2006-04-18 17:59 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: mrl at conectiva dot com dot br Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 5.1.2 OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mrl at conectiva dot com dot br
New email:
PHP Version: OS:

 

 [2006-04-18 17:21 UTC] mrl at conectiva dot com dot br
Description:
------------
At pear/install-pear-nozlib.phar for php 5.1.2 and at 
pear/PEAR/Config.php for php 4.4.2 there is the sequence:

// Default for php_dir
if (getenv('PHP_PEAR_INSTALL_DIR')) {
    define('PEAR_CONFIG_DEFAULT_PHP_DIR', 
getenv('PHP_PEAR_INSTALL_DIR'));
} else {
    if (@is_dir($PEAR_INSTALL_DIR)) {
        define('PEAR_CONFIG_DEFAULT_PHP_DIR',
               $PEAR_INSTALL_DIR);
    } else {
        define('PEAR_CONFIG_DEFAULT_PHP_DIR', 
$PEAR_INSTALL_DIR);
    }
}

Please note that the blocks controled by the if(@is_dir) 
are just the same. So either we wouldn't need the check, 
or the second block is mistyped.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-18 17:59 UTC] bjori@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Please report bugs in PEAR at http://pear.php.net/bugs/report.php?package=PEAR
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 29 08:01:27 2020 UTC