php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37015 I need help with my music submission page it keeps trying to download the file.
Submitted: 2006-04-08 02:34 UTC Modified: 2006-04-08 11:44 UTC
From: promotions at chicagomusicpromotions dot com Assigned:
Status: Not a bug Package: PHP options/info functions
PHP Version: 4.4.2 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: promotions at chicagomusicpromotions dot com
New email:
PHP Version: OS:

 

 [2006-04-08 02:34 UTC] promotions at chicagomusicpromotions dot com
Description:
------------
Ok on this page here

http://www.chicagomusicpromotions.com/musicsubmission.htm  

when the people enter their information

and they add their photo and also as well their mp3

once it gets done sending its suppost to refresh back to the main page.

Well for some reason its not doing that and its asking them to download the process32.php file thats located on the server that process's the form page  any suggestions?

Reproduce code:
---------------
<?php

@extract($_POST);
$name = stripslashes ($name);
$email = stripslashes ($email);
$subject = stripslashes ($subject);
$text = stripslashes ($text);
$uploaddir = 'uploadphoto/';
$uploadfile = $uploaddir . basename($_FILES['ImageFile']['name']);
if (file_exists ($uploadfile)) {
	//
$message="This file already exists, please rename the file and re-upload";
} else {
	move_uploaded_file($_FILES['ImageFile']['tmp_name'], $uploadfile);
}

$photopath="http://www.chicagomusicpromotions.com/".$uploadfile;

$uploaddir2 = 'uploadmp3/';
$uploadfile2 = $uploaddir2 . basename($_FILES['MusicFile1']['name']);
if (file_exists ($uploadfile2)) {
	//$message="This file already exists, please rename the file and re-upload";
} else {
	move_uploaded_file($_FILES['MusicFile1']['tmp_name'], 
$uploadfile2);
}
$mp3path="http://www.chicagomusicpromotions.com/".$uploadfile2;
$message = $name . "\n" . $email . "\n" . $subject . "\n" . $cmail . "\n" . $city . "\n" . $state . "\n" . $zip . "\n" . $telephone . "\n" . $services . "\n" . $website . "\n" . $url . "\n" . $photopath. "\n" . $mp3path. "\n" . $text;
mail ('promotions@chicagomusicpromotions.com',$subject,$message,"From: $name <$email>");
mail ('espringer@chasetheweb.net',$subject,$message,"From: $name <$email>");
header ("location:http://www.chicagomusicpromotions.com/");
//$fdf = fdf_open_string($HTTP_FDF_DATA); 
//$data = fdf_get_attachment($fdf, "filename", "/uploadmp3");
?>

Expected result:
----------------
its going to ask you to download the php file for the header information and well i dont know how to fix that.


Actual result:
--------------
its suppost to go back to 

http://www.chicagomusicpromotions.com

after the info has been submitted.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-08 11:44 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 20:01:24 2020 UTC