php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36979 Cant set COM properties
Submitted: 2006-04-05 03:32 UTC Modified: 2006-04-05 06:35 UTC
From: sharonlp at hotmail dot com Assigned:
Status: Not a bug Package: COM related
PHP Version: 5.1.2 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sharonlp at hotmail dot com
New email:
PHP Version: OS:

 

 [2006-04-05 03:32 UTC] sharonlp at hotmail dot com
Description:
------------
I am using PHP 5.1.2 on Apache 2.0. In my PHP code I am trying to set a COM OLE poprerty:

$simcase->ObjectValue($inobj1, $inpropname1,"",$inunits1)=$inval1;

($simcase is a COM object)

Using:

echo $simcase->ObjectValue($inobj1, $inpropname1,"",$inunits1);

works fine.

Expected result:
----------------
I expected the method to execute and set the property without any problem. According to the type library what I have written is perfectly legal and works with VBScript etc.

   HRESULT ObjectValue([in] IDispatch* object, [in] BSTR variable, [in,optional] BSTR subVariable, [in,optional] BSTR units, [out, retval] double* value);
   [helpstring("Sets"),propput,helpcontext(NO_HELP_PANEL)]

   HRESULT ObjectValue([in] IDispatch* object, [in] BSTR variable, [in,optional] BSTR subVariable, [in,optional] BSTR units, [in] double value);
   [helpstring("Gets"),propget,helpcontext(NO_HELP_PANEL)]



Actual result:
--------------
Fatal error: Can't use method return value in write context...

With com_set being gone, I cant find any work around. I also found a comment somewhere saying "we cant support ()= so we have "[]=".

But what do you do if your property also takes arguments?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-05 06:35 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 09 06:03:45 2022 UTC