php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3693 Over 232 virtuals, and php gives "Document contains no data"
Submitted: 2000-03-01 17:42 UTC Modified: 2002-09-30 20:10 UTC
From: flood at sevensages dot org Assigned:
Status: Not a bug Package: Reproducible Crash
PHP Version: 3.0.15 OS: Solaris 7/x86
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: flood at sevensages dot org
New email:
PHP Version: OS:

 

 [2000-03-01 17:42 UTC] flood at sevensages dot org
From apache error log:  Possible PHP3 memory leak detected (harmless):  38 bytes from request_info.c:205

This happens on Solaris 7.  If compiled as a DSO, or if compiled in, this happens.

./configure --with-apxs=/usr/local/etc/httpd2/bin/apxs \
	--with-mysql=/usr/local/mysql  \
	--enable-track-vars  \
	--enable-debug

It doesn't matter what version of php is used, even php4.  Since it was giving the mysterious, "Document contains no data", I decided to compile with "--enable-debug".  That's when I get the message in the apache log files.

With 232 virtuals, it is fine.  With 233, it breaks. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-30 20:10 UTC] hholzgra@php.net
you've hit the file handle limit for this operatings system
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jun 03 13:01:25 2020 UTC