php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36919 Strange MySQLi Behaviour
Submitted: 2006-03-30 02:00 UTC Modified: 2006-06-28 01:00 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: antimon at gmail dot com Assigned: georg (profile)
Status: No Feedback Package: MySQLi related
PHP Version: 5.1.2 OS: Win32
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: antimon at gmail dot com
New email:
PHP Version: OS:

 

 [2006-03-30 02:00 UTC] antimon at gmail dot com
Description:
------------
Hi,
I use apache 2.0.55 with php 5.1.2. And this is my simple php source:

$m = mysqli_connect("localhost", "root", "253263", "dictsite");
$st = $m->prepare($sql);

$p = "page ismi";
$st->bind_param("s", $p);
$st->execute();

$st->bind_result($c1, $c2, $c3, $c4, $c5);

while ($st->fetch()) {
print_r($c1);
}

This runs ok. But if i add
$sp->store_result(); after execute call, it causes apache to restart itself noting this:
"[Thu Mar 30 02:53:15 2006] [notice] Parent: child process exited with status 0 -- Restarting."

One other issue is the known multiple recordsets returned from stored procedure queries.

So, i used the latest libmysql from mysql distro, it did not even pushed any variables to bind_result parameters.

And i used mysqli and libmysql from "http://dev.mysql.com/downloads/connector/php/" and eveything works fine. (http://bugs.mysql.com/bug.php?id=14993 is fixed too)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-30 10:22 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip


 [2006-03-30 10:59 UTC] antimon at gmail dot com
Tried latest win32 snapshot. Same results. BTW, store_result() call crashes on TEXT fields i think. Not sure.
 [2006-06-20 15:20 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip


 [2006-06-28 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 16:05:45 2022 UTC