php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #369 Connecting to a ODBC Source my hd swap too much
Submitted: 1998-05-10 19:57 UTC Modified: 1998-05-10 21:48 UTC
From: andrea at conmet dot it Assigned: shane (profile)
Status: Closed Package: ODBC related
PHP Version: 3.0 Release Candidate 4 OS: Windows NT
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andrea at conmet dot it
New email:
PHP Version: OS:

 

 [1998-05-10 19:57 UTC] andrea at conmet dot it
Well, connecting to a ODBC source my hd start to swap too much
and I load pages (on the local machine) at 1.5 kb/s.
PHP run on a NT box with Apache 1.3b6

This script reproduce my problem:

<? 

	$dbh = odbc_connect($dsn,$usr,$pwd);
	$result = odbc_exec($dbh,$query);
	odbc_fetch_row($result);
	echo ">>";
	echo odbc_result($result,0);
?>

Configuration:

PC Pentium 133MhZ 32Mb Ram
Windows NT 4.0 sp 3
PHP 3.0RC4
Apache 1.3b6
The odbc driver is MyODBC 2.50.15 for NT

The binary and the php.ini file are unmodified from the
distribution file.

P.S.: Connecting directly to the MySQL server with the mysql
functions this problem doesn't appear.

Best Regards
Andrea Bettarini 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-05-10 21:48 UTC] shane
Closing due to lack of useful information.  For all we know, you could be selecting 10Gig of data on a machine with 32 mb ram.

Here are some things to try:
use an access or dbase odbc connection with the same data and query and see if it has the same results.  If not, MyODBC is the culprit, if so, you'll have to give some idea as to the size of the data being selected, number of rows, what the sql statement is.  The sample script provided does not work 'as-is'.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 20 06:01:23 2020 UTC