php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36892 troubles with odbc_connect on visual foxpro db
Submitted: 2006-03-28 14:35 UTC Modified: 2012-04-18 10:42 UTC
Votes:3
Avg. Score:4.3 ± 0.5
Reproduced:0 of 0 (0.0%)
From: anonymous at gmail dot com Assigned:
Status: Closed Package: *Database Functions
PHP Version: 5.1.2 OS: Win 2000 pro
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: anonymous at gmail dot com
New email:
PHP Version: OS:

 

 [2006-03-28 14:35 UTC] anonymous at gmail dot com
Description:
------------
on a computer with Win 2000 pro, i try to connect to a visual foxpro db with php 5.1 function odbc_connect, but it s failed (of course odbc driver is installed). i do the same connexion with php 4.3 and all is good. more: i do both tests on a computer with Win XP and i see no troubles... did this trouble is reported before (it s seems not) and have you a solution
thanks for your help.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-28 14:50 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip


 [2006-03-28 15:59 UTC] the_yann at hotmail dot com
i m not sure to undestand: you offer to install php last version ? i try with easyphp (php 4.3.10) wamp (php5.1.2) and xampp (php 5.1.1) and no one with 5.1.x accept to connect with the visual foxpro db...
 [2006-03-28 16:07 UTC] tony2001@php.net
Yes, I want you to try plain PHP.
Not WAMP, XAMP or xxxP. Just plain PHP. 
 [2006-03-28 16:09 UTC] the_yann at hotmail dot com
i also try on a computer with Win XP and the php 5.1.x running well but the server is on Win 2000 XP and then it s failed
 [2006-03-28 16:14 UTC] tony2001@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc.

If possible, make the script source available online and provide
an URL to it here. Try to avoid embedding huge scripts into the report.

I'm afraid "failed" is not enough to understand the problem.

 [2006-03-28 16:34 UTC] the_yann at hotmail dot com
i m working localy (so i can t offer you to try on-line)

Admin ODBC - User data sources:
PFLEX        Microsoft FoxPro VFP Driver (*.dbf)
Config - Path:
c:\Documents and Settings\Administrateur\Mes documents\PFlex\GpDEV\STOCK

simple source:
<?php
	$pflexhdl = odbc_connect('PFLEX','','');
?>

Result:
Warning: odbc_connect() [function.odbc-connect]: SQL error: [Microsoft][ODBC Visual FoxPro Driver]SourceDB, SQL state 01S00 in SQLConnect
 [2006-03-28 16:44 UTC] the_yann at hotmail dot com
and the problem is on a computer with Win 200 pro and with php 5.1.x, not with win 2000 pro and php 4.3.x, and not with win XP and php 5.1.x
i want to use php 5 but not re-install my server in win XP.
 [2006-03-28 23:39 UTC] kalowsky@php.net
Can you establish a connection to the DB on Win2000 without PHP?  
 [2006-03-29 08:10 UTC] the_yann at hotmail dot com
i can connect to the db with ms query and with php4 but not with php5
 [2006-03-29 18:30 UTC] kalowsky@php.net
Under the ODBC Data Source Administrator, can you execute a test connection?  Is this a User, System, or File DSN?

The error you're seeing (SQLState 01S00) basically says you have given an invalid connection string/DSN, at least from what I remember off hand.  That suggests this isn't a bug in PHP but rather a misconfiguration.  
 [2006-03-30 08:13 UTC] the_yann at hotmail dot com
i got no more troubles but i don t know really why.
i do nothing special... sorry and thanks
 [2012-04-18 10:42 UTC] anonymous at gmail dot com
del email
 [2012-04-18 10:42 UTC] anonymous at gmail dot com
-: the_yann@hotmail.com +: anonymous at gmail dot com
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 06:01:28 2019 UTC