php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36842 Linked with libiconv library , but phpinfo say glibc
Submitted: 2006-03-24 10:48 UTC Modified: 2006-03-24 11:27 UTC
From: dima at sweb dot ru Assigned:
Status: Not a bug Package: ICONV related
PHP Version: 5.1.2 OS: Red Hat Linux release 8.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: dima at sweb dot ru
New email:
PHP Version: OS:

 

 [2006-03-24 10:48 UTC] dima at sweb dot ru
Description:
------------
On the system with installed libiconv library php don't see
iconv() function (Fatal error: Call to undefined function iconv() ) but in phpinfo say that it's implemented throuh glibc.

Reproduce code:
---------------
Any use of iconv() function gets: Fatal error.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-24 11:01 UTC] tony2001@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2006-03-24 11:08 UTC] dima at sweb dot ru
php was compiled with the following options:

./configure  \
'--prefix=/opt/php5' \
'--with-mysql=/usr' \
'--with-config-file-path=/etc/opt/php5' \
'--enable-force-cgi-redirect' \
'--disable-debug' \
'--enable-pic' \
'--disable-rpath' \
'--enable-inline-optimization' \
'--with-freetype-dir=/usr/local' \
'--with-png-dir=/usr' \
'--with-gd' \
'--enable-gd-native-ttf' \
'--with-mime-magic' \
'--without-gdbm' \
'--with-gettext' \
'--with-jpeg-dir=/usr' \
'--with-curl' \
'--with-curlwrappers' \
'--enable-ftp' \
'--enable-mbstring' \
'--with-xml' \
'--with-xsl' \
'--with-expat-dir=/usr' \
'--with-dom=shared,/usr' \
'--with-dom-xslt=/usr' \
'--with-dom-exslt=/usr' \
'--with-xmlrpc=shared' \
'--with-pcre-regex' \
'--with-zlib' \
'--enable-bcmath' \
'--enable-magic-quotes' \
'--enable-sockets' \
'--enable-sysvshm' \
'--enable-track-vars' \
'--enable-trans-sid' \
'--with-pgsql=/usr/bin/pg_config' \
'--enable-memory-limit' \
'--with-snmp' \
'--enable-soap' \
 [2006-03-24 11:10 UTC] tony2001@php.net
Reconfigure it with just `./configure --with-iconv=/usr` and see if it helps.
 [2006-03-24 11:24 UTC] dima at sweb dot ru
Helps it or not it's a bug. Because of wrong phpinfo.
 [2006-03-24 11:27 UTC] tony2001@php.net
No bug, but a libraries/headers mess in your system.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 27 08:03:36 2021 UTC