php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36768 Email addresses easily harvested
Submitted: 2006-03-17 08:13 UTC Modified: 2008-11-28 23:39 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: phpbug at chipple dot net Assigned:
Status: Wont fix Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: phpbug at chipple dot net
New email:
PHP Version: OS:

 

 [2006-03-17 08:13 UTC] phpbug at chipple dot net
Description:
------------
The way email addresses are currently obfuscated in the documentation and on bugs.php.net makes it easy for spammers to harvest them just by sending queries to Google.

For example, the Google search queries:
  "* at * dot *" site:php.net
  "* at * dot * dot *" site:php.net
match tons of email addresses, and Google even makes it easy to parse them out since they're highlighted in bold in the results.

It would be a good thing if the php.net site would obfuscate users' email addresses in a non-Googleable manner such as removing spaces around "at" and "dot" (e.g. bugsATphpDOTnet) or similar.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-11-28 23:39 UTC] danbrown@php.net
This is still the unwritten standard for plain-text email obfuscation, so at this time the issue won't be fixed.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Sep 27 15:05:53 2022 UTC