php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36676 PDO resultset for Firebird does not return 1st row values
Submitted: 2006-03-10 08:09 UTC Modified: 2006-03-10 13:32 UTC
From: astro101 at hotmail dot com Assigned:
Status: Not a bug Package: PDO related
PHP Version: 5.1.2 OS: Win XP SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: astro101 at hotmail dot com
New email:
PHP Version: OS:

 

 [2006-03-10 08:09 UTC] astro101 at hotmail dot com
Description:
------------
When querying a firebird database with pdo the values returned for the 1st row of the resultset are empty.
If you change your order or delete a entry the 1st row values  still return nothing.

Reproduce code:
---------------
$db = new PDO ("firebird:dbname=localhost:c:/mydb.fdb", 'SYSDBA', 'masterkey');

try{
  $query = 'select * from HandsetsMake;';
  $res = $db->query($query);
  while($row = $res->fetch(PDO::FETCH_NUM)){
    echo 'Result: '.$row[0].'<br />';
  }
  $cms->commit();
}catch (Exception $e){
  echo 'caught exeption: '.$e->getLine().$e->getMessage();
}

Expected result:
----------------
Result:1
Result:2
Result:3
Result:4



Actual result:
--------------
Result:
Result:2
Result:3
Result:4

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-10 09:11 UTC] astro101 at hotmail dot com
I also found with the latest snapshop (php5.1-win32-200603100330.zip) that i could not connect to the firebird database.
 [2006-03-10 13:32 UTC] mike@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Dupe of bug #35386

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Mar 03 09:01:23 2021 UTC