php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36620 Failing to start Apache after compiling PHP 4.3.8
Submitted: 2006-03-05 19:32 UTC Modified: 2006-03-06 15:08 UTC
From: bnatal at tsp dot sheridan dot com Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 4CVS-2006-03-05 (snap) OS: Solaris 2.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bnatal at tsp dot sheridan dot com
New email:
PHP Version: OS:

 

 [2006-03-05 19:32 UTC] bnatal at tsp dot sheridan dot com
Description:
------------
I'm compiling PHP 4.3.8 on a web server running Apache/2.0.52 (i.e. Solaris 2.8 system).

Trying to compile using. I already install and compiled Sablotron 1.0.2 from source.

./configure --enable-shared --with-pear --with-apxs2=/usr/local/apache/bin/apxs --with-zlib \
--enable-ftp --enable-cli --enable-xslt --with-xslt-sablot --with-curl=/usr/local --enable-force-cgi-redirect --enable-discard-path \
--with-mssql=/usr/local --with-openssl=/usr/local/ssl --with-mysql=/usr/local/mysql --with-mysqli=/usr/local/mysql/bin/mysql_config \
--enable-calendar --prefix=/usr/local/apache/php

Here is the error message when attempting to restart Apache.

Syntax error on line 231 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server: ld.so.1: /usr/local/apache/bin/httpd: fatal: relocation error: file /usr/local/lib/libstdc++.so.6: symbol __eprintf: referenced symbol not found


I've referenced the bug #33425, but did not have any luck after following similiar steps. Please let me know how can I fix this issue.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-05 19:35 UTC] tony2001@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2006-03-05 20:01 UTC] bnatal at tsp dot sheridan dot com
Installed / compiled the latest PHP version 4.4.2. However, I'm still getting the error message below when trying to start apache.

Syntax error on line 231 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/lib/libstdc++.so.6: symbol __eprintf: referenced symbol not
found

Any suggestions?
 [2006-03-05 20:23 UTC] bnatal at tsp dot sheridan dot com
I've tried your recommendations but continue to get the same error message. Any other recommendations that I can try next?
 [2006-03-06 14:47 UTC] tony2001@php.net
Does the problem appear when you use GNU make and GNU ld ?
 [2006-03-06 14:52 UTC] bnatal at tsp dot sheridan dot com
Not really, I'm able to try it on a test Solaris box running the same version of PHP and Apache and it works fine. But when I try to compile using --enable-xslt --with-xslt-sablot and restart apache it errors on this server. What can cause this error message to occur? Are there any links that could be causing this problem?

Syntax error on line 231 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/lib/libstdc++.so.6: symbol __eprintf: referenced symbol not
found
 [2006-03-06 15:08 UTC] tony2001@php.net
So it looks like you have some problems with your building environment and this is definitely not PHP problem.
Make sure that you're using gmake and GNU ld, it should work fine.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 01:01:25 2020 UTC