php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36616 SoapClient calls
Submitted: 2006-03-05 09:45 UTC Modified: 2006-03-05 09:52 UTC
From: dennisyerger84 at comcast dot net Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.1.2 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dennisyerger84 at comcast dot net
New email:
PHP Version: OS:

 

 [2006-03-05 09:45 UTC] dennisyerger84 at comcast dot net
Description:
------------
I've been using php to create web services and experiment with them. One of the things I think is important to web services is true object functionality, which means setting a value and being able to retrieve that same value later. For example, if I want to call an operation (a setter) to set a certain value for an instance of a service port, I want to be able to retrieve that same value with a call to other operation (a getter) if I wanted to. The problem I've been having is when I make more than one operation call on a single instance of SoapClient. However, this problem only occurs when I use another php script as the service port itself. In other words, I'm using php at both ends: client and server. But when the service port is, say, a coldfusion component, I get no trouble at all. Could this be an issue with the web server I'm running? I am running Abyss Web Server X1 for both my client and server scripts.

Reproduce code:
---------------
client side script:
$c = new SoapClient("http://localhost/session.php?wsdl");
$c->setString("my name is dennis");
echo $c->getString(); //this causes the error. If I called this first it would cause no trouble until I made another call to an operation

server side script:
//Session class definition goes above the follwing code:
$server = new SoapServer("Session.wsdl");
$server->setClass("Session");
$server->setPersistence(SOAP_PERSISTENCE_SESSION);
$server->handle();

Expected result:
----------------
my name is dennis

Actual result:
--------------
SoapFault exception: [HTTP] Error Fetching http headers in C:\Program Files\Abyss Web Server\htdocs\client.php:9
Stack trace:
#0 [internal function]: SoapClient->__doRequest('<?xml version="...', 'http://localhos...', 'http://tempuri....', 1)
#1 [internal function]: SoapClient->__call('getString', Array)
#2 C:\Program Files\Abyss Web Server\htdocs\client.php(9): SoapClient->getString()
#3 {main}	

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-05 09:47 UTC] dennisyerger84 at comcast dot net
minor edit
 [2006-03-05 09:52 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Mar 26 00:01:27 2019 UTC