php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36572 Can't execute "show master status"
Submitted: 2006-03-01 14:59 UTC Modified: 2006-03-05 18:18 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:2 (100.0%)
From: nerve at gmx dot net Assigned:
Status: Closed Package: PDO related
PHP Version: 5.1.2 OS: Gentoo Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
18 + 26 = ?
Subscribe to this entry?

 
 [2006-03-01 14:59 UTC] nerve at gmx dot net
Description:
------------
The problem is the same problem as the bug with the 
nuber 36347, but the solution is for this statemnts not practicable..

What to do with the statement 'show master status' or 'show slave status' ?
This statements return a result set, and im interessed in the result set.
You actually can't use PDO::query() with this statements:

HY000:2030:This command is not supported in the prepared statement protocol yet

Using of PDO::exec() isn't a option, i want the result set!

Please help me !
Releases: php 5.1.2 on gentoo linux with mysql 5.0.18
Daniel Heule



Reproduce code:
---------------
try to execute the MySql statement 'show master status' with pdo ...

Expected result:
----------------
the result set of this query ....

Actual result:
--------------
an sql error

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-05 18:18 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 17:03:35 2021 UTC