php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3655 Function "imap_getmailboxes()" doesn't work as expected
Submitted: 2000-02-28 14:55 UTC Modified: 2000-02-28 16:05 UTC
From: ptuasca at hotmail dot com Assigned:
Status: Closed Package: IMAP related
PHP Version: 4.0 Beta 4 Patch Level 1 OS: Solaris 2.5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ptuasca at hotmail dot com
New email:
PHP Version: OS:

 

 [2000-02-28 14:55 UTC] ptuasca at hotmail dot com
Function "imap_getmailboxes()" doesn't return the mailbox name as expected. The following code (working fine with php 3.0.14) stopped working:

<?
$mailstream=imap_open('{127.0.0.1:143}','usr','pwd');
$list=imap_getmailboxes($mailstream,'{127.0.0.1:143}','*');

  for($i = 0; $i < count($list); $i++)
      echo($list[$i]->name);
?>

The "configure" line:

./configure \
--with-imap \
--with-mysql=/usr/local/mysql \
--with-gd \
--with-ttf \
--with-ftp \
--with-xml \
--with-apxs=/usr/local/apache/bin/apxs \
--enable-track-vars \
--enable-versioning \
--with-config-file-path=/etc;

What I'm doing wrong?
Thanks,
PTuasca

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-02-28 16:05 UTC] chagenbu at cvs dot php dot net
It was segfaulting because of some problems converting over
to the Zend API. These should be fixed now - please try the
latest 4.0 CVS.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 21:03:39 2021 UTC