php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36546 just only got "Object id #2"
Submitted: 2006-02-27 18:47 UTC Modified: 2006-02-27 18:50 UTC
From: roderja at hotmail dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.1.2 OS: windows xp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: roderja at hotmail dot com
New email:
PHP Version: OS:

 

 [2006-02-27 18:47 UTC] roderja at hotmail dot com
Description:
------------
PHP call the web services which was wrote by ASP.NET.
Just only got "Object id #2" Thanks.
By the way, please tell me where can I get the detail PHP web services bible. Thanks.

Reproduce code:
---------------
&#65279;&#65279;&#65279;<HTML>
<head> 
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"> 
</head>
<title>Ja page</title>
<body> 
<?php
//call web services 
$wsdl_loc = "http://localhost:1071/WebSite3/Service.asmx?WSDL";
$soap_client = new SoapClient($wsdl_loc);
$result = $soap_client->SayHello();
//change to next line
echo ("<p></p>");   
echo $result;                        
?>
</body>
</html>

=============================following is ASP.NET
Imports System.Web
Imports System.Web.Services
Imports System.Web.Services.Protocols

<WebService(Namespace:="http://tempuri.org/")> _
<WebServiceBinding(ConformsTo:=WsiProfiles.BasicProfile1_1)> _
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class Service
     Inherits System.Web.Services.WebService

    <WebMethod()> _
    Public Function SayHello() As String
        Return "Hello"
    End Function

End Class

Expected result:
----------------
Hello

Actual result:
--------------
Object id #2 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-27 18:50 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Mar 22 20:01:27 2019 UTC