php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36497 __halt_compiler get parsing error with arguments
Submitted: 2006-02-23 10:42 UTC Modified: 2006-02-23 10:47 UTC
From: chen dot daqi at gmail dot com Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 5.1.2 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chen dot daqi at gmail dot com
New email:
PHP Version: OS:

 

 [2006-02-23 10:42 UTC] chen dot daqi at gmail dot com
Description:
------------
__halt_compiler get parsing error with argument.

Reproduce code:
---------------
<?php
__halt_compiler(1);
?>

Expected result:
----------------
Warning of argument numbers or just exit normally

Actual result:
--------------
Parse error: syntax error, unexpected T_LNUMBER, expecting ')' __halt_compiler.php on line 2


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-23 10:47 UTC] derick@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

You\'re making a syntax error... so you get a parse error.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 07:01:24 2020 UTC