|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36472 Memory fault
Submitted: 2006-02-21 10:44 UTC Modified: 2006-03-01 01:00 UTC
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: Eskil dot Swahn at LDC dot lu dot se Assigned:
Status: No Feedback Package: Apache related
PHP Version: 4.4.2 OS: Tru64 UNIX V5.1B
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: Eskil dot Swahn at LDC dot lu dot se
New email:
PHP Version: OS:


 [2006-02-21 10:44 UTC] Eskil dot Swahn at LDC dot lu dot se
I have failed to upgrade our PHP-installation on Tru64 UNIX to 4.4.1 or 4.4.2 (successful on Linux and Solaris).

When I try to restart Apache after copying a new I get a crash which only lists the following:

bin/apachectl: 814341 Memory fault
bin/apachectl startssl: httpd could not be started

This setup has worked flawlessly upto 4.4.0 but both 4.4.1 and 4.4.2 triggers this behaviour.


./configure  --with-apache=../apache_1.3.33 --with-prefix=/usr/local/php --with-oci8=/usr/users/dba/oracle/product/9.2.0 --with-openssl

I can find no further information in any of Apache's logfiles.

This is a setup with Apache 1.3.33 and mod_ssl 2.8.22.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-21 10:51 UTC]
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read for *NIX and for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
 [2006-02-21 11:12 UTC] Eskil dot Swahn at LDC dot lu dot se
Checked the instructions for generating a backtrace.

Any chance of instructions for T64's dbx instead of gdb?
 [2006-02-21 11:17 UTC]
No, you're on your own for that... but your best bet would be to start apache in single process mode (-X) in the debugger and then request your script. The debugging should capture it when it segfaults and i guess there is a command to make a backtrace then.
 [2006-02-21 15:05 UTC] Eskil dot Swahn at LDC dot lu dot se
I have generated a core file and I am waiting on help from HP on how to handle the debugger. My session so far:

dbx version 5.1
Type 'help' for help.
Core file created by program "httpd"

thread 0x4 signal Segmentation fault at >*[strcmp, 0x3ff800d8334]       ldq_u   t1, 0(a1)
(dbx) help
  Command syntax:  "help <keyword>",  <keyword> is one of the following list:

    most_used, quit, alias, record, playback, history, lineedit, run, 
    rerun, stop, step, next, trace, delete, catch, ignore, 
    cont, return, when, goto, print, printx, printo, printd, 
    printf, printregs, where, status, whatis, which, whereis, assign, 
    tag, up, down, func, dump, display, list, search, 
    edit, file, use, set, setenv, sh, stopi, conti, 
    stepi, nexti, tracei, listobj, enable, disable, kernel, tlist, 
    tset, tstack, call, attach, detach, plist, switch, variable, 
    register, builtin, expression

(dbx) trace
     ^ syntax error
(dbx) help trace
trace <exp>                    - print <exp> when it changes
trace <exp> at <line>          - print <exp> when <line> is reached
trace <exp> in <proc>          - print <exp> when call <proc>
trace <exp> at <line> if <exp> - print <exp> when <line> is reached and <exp>
trace <exp> in <proc> if <exp> - print <exp> when call <proc> and <exp>
(dbx) quit

Does this help in any way so far?
 [2006-02-21 15:07 UTC] Eskil dot Swahn at LDC dot lu dot se
Something that was interesting as well was that 'httpd -X' doesn't coredump, it's not until I run 'apachectl startssl' that I trigger the memory fault..
 [2006-03-01 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Apr 20 05:01:27 2024 UTC