php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36468 problem with 127.0.0.1 and localhost
Submitted: 2006-02-20 22:47 UTC Modified: 2006-02-21 10:05 UTC
From: imo at popular dot lv Assigned:
Status: Not a bug Package: *Network Functions
PHP Version: 5.1.2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: imo at popular dot lv
New email:
PHP Version: OS:

 

 [2006-02-20 22:47 UTC] imo at popular dot lv
Description:
------------
problem with file_get_contents, fread an stream_get_content
on windows all works fine, but on linux not work :(



Reproduce code:
---------------
<?
echo file_get_contents("http://127.0.0.1/somedir/somefile.php");
// result: blank or fatall error 0

echo file_get_contents("http://mydomain.lv/somedir/somefile.php");
//all works fine

echo file_get_contents("http://localhost/somedir/somefile.php");
//all works fine
?>



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-21 10:05 UTC] bjori@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Configure your OS/httpd correctly (/etc/hosts for instance)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Oct 18 16:01:28 2019 UTC