php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36462 error when connect database from network
Submitted: 2006-02-20 15:08 UTC Modified: 2006-02-20 15:23 UTC
From: far_mai at yahoo dot com Assigned:
Status: Not a bug Package: ODBC related
PHP Version: 4.4.2 OS: windowsxp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
10 + 39 = ?
Subscribe to this entry?

 
 [2006-02-20 15:08 UTC] far_mai at yahoo dot com
Description:
------------
error php connect database foxpro  from network but run on my PC is no problem

Reproduce code:
---------------
<?php
 $conn=odbc_connect('test','','' ); 
if (!$conn)
{exit("Connection Failed: " . $conn); } 
else{

		echo"<br> pass  s";
		echo $sql="SELECT order_no  from order  "; 
		echo"<br> ".$rs=odbc_exec($conn,$sql);
}
  
?>  

Expected result:
----------------
Warning: odbc_exec(): SQL error: [Microsoft][ODBC Visual FoxPro Driver]File 'cusmst.dbf' does not exist., SQL state S0002 in SQLExecDirect



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-20 15:23 UTC] mike@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Create the appropriate Datasource then.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Apr 06 13:01:25 2020 UTC