php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36408 "cvs checkout phpdoc-all" doesn't check out Japanese (and Korean) documentation
Submitted: 2006-02-16 04:15 UTC Modified: 2006-07-24 21:05 UTC
From: takagi@php.net Assigned:
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: takagi@php.net
New email:
PHP Version: OS:

 

 [2006-02-16 04:15 UTC] takagi@php.net
Description:
------------
Documentation Howto says
> You also have the ability of checking out infrastructure
> the complete build and all the languages.
> You can do this with:
> $ cvs checkout phpdoc-all
(http://doc.php.net/php/dochowto/cvs-checkout.php)

but we can't check out Japaneese (and Korean) documentation by this command.


Reproduce code:
---------------
$ cvs -d:pserver:cvsread@cvs.php.net:/repository login
$ cvs -d:pserver:cvsread@cvs.php.net:/repository checkout phpdoc-all
$ ls phpdoc-all/ja/


Expected result:
----------------
Same as the following.
$ cvs -d:pserver:cvsread@cvs.php.net:/repository login
$ cvs -d:pserver:cvsread@cvs.php.net:/repository checkout phpdoc-ja-dir
$ ls ja/


Actual result:
--------------
The directory is empty (only 'CVS' directory exists).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-16 04:22 UTC] takagi@php.net
When I do
$ cvs -d:pserver:cvsread@cvs.php.net:/repository checkout phpdoc-all

,the following messages are displayed. 
> cvs checkout: existing repository /repository/phpdoc/ja does not match /repository/phpdoc-ja
> cvs checkout: ignoring module phpdoc-ja-dir
> cvs checkout: existing repository /repository/phpdoc/kr does not match /repository/phpdoc-kr
> cvs checkout: ignoring module phpdoc-kr-dir
 [2006-02-16 09:17 UTC] derick@php.net
There is nothing different in the configuration for those directories...
 [2006-02-16 10:01 UTC] takagi@php.net
Perhaps the existence of '/repository/phpdoc/ja' and '/repository/phpdoc/kr' causes this problem.

Please take a look at the following url.
 http://cvs.php.net/viewcvs.cgi/phpdoc/

We can see 'ja' and 'kr', but can't see any other (e.g. 'de','fr','it',...).
 [2006-02-21 20:22 UTC] nlopess@php.net
Ye, it might be because of the existence of old (but now empty) ja and kr dirs.
Derick, can you please delete the files on server side to see if it fixes the problem?
 [2006-07-24 21:05 UTC] takagi@php.net
Fixed by Sean (http://news.php.net/php.doc/969373578). Thank you!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Apr 12 07:01:24 2021 UTC