php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36394 Error Fetching http headers
Submitted: 2006-02-14 21:34 UTC Modified: 2006-04-18 11:39 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: nd_ngoka at xyratex dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.1.2 OS: Mandrake 10.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nd_ngoka at xyratex dot com
New email:
PHP Version: OS:

 

 [2006-02-14 21:34 UTC] nd_ngoka at xyratex dot com
Description:
------------
I installed php5-soap-5.0.2-1mdk, apache and php5 unto my mandrake 10.1 box. I intend to use the soap feature to communicate with another soap server, in other to receive a licence key.

When I execute the php script that communicates with the soap server, I get the following error code :
faultcode : HTTP
fault string : Error Fetching http headers


I am not able to make sense of this error code, as it doesn't indicate if the problem is from the server side or client side.


Your help will be grately apprieciated.

Reproduce code:
---------------
$location= "https://??????soapRegistrationServer.php";
$soap_uri = "http://?????????soapRegistrationServer";


$params = array('local_cert' => "?????.key",
                'location' => $location,
		'uri' => $soap_uri,
                'exceptions' => 0);
$client = new SoapClient(null,$params);
$fkparams = array('user' => "username",
                  'password' => "paswword");
$newkey = $client->__soapCall('get_key', $fkparams);
if (is_soap_fault($newkey)) {
  echo "SOAP Fault: (faultcode: ".$newkey->faultcode.", faultstring: ".$newkey->faultstring."\n";
}

echo $newkey."\n";
?>

Expected result:
----------------
The script is might to return a key

Actual result:
--------------
faultcode : HTTP
fault string : Error Fetching http headers

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-14 21:48 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip


 [2006-02-14 22:43 UTC] nd_ngoka at xyratex dot com
http://snaps.php.net/php5.1-latest.tar.gz

The above link contains a full version of PHP5.
Are you saying that the current PHP 5 (version 5.02) that I am using has a bug it .


Are you recommending I uninstall the current version I have and then build this version.

Please give me more detail on what your suggestion is.

Thanks in advance.
 [2006-02-14 22:55 UTC] tony2001@php.net
I'm asking you to try the latest snapshot and to let us know if you're still able to reproduce the problem.
I'm asking you to do it because you're using pretty oudated version 5.0.2 and there were a lot of changes since this version.
 [2006-02-22 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2006-04-13 17:44 UTC] Brian dot Reynolds at risaris dot com
Hi, 

I too am getting the "Error fetching http headers" problem. The web service is sitting on an SSL enabled Apache.

I'm running PHP 5.1.2 - downloaded and built today ;-)

PHP 5.1.2 (cgi) (built: Apr 13 2006 17:02:04)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

running on SuSE 9.2 

This is my code:

<?php
 
ini_set("soap.wsdl_cache_enabled", "0"); // disabling WSDL cache
 
$soapClient = new SoapClient( "https://dublin/adabas/Employees?WSDL" , array('allow_self_signed' => true) );
 
$adabasEmployeeGetKey = array('personnel_id'=>50005000);
 
try{
        $results = $soapClient->get($adabasEmployeeGetKey);
}
catch( Exception $e){
 
        print "An exception occurred!\n";
        print "Code : ";
        print_r( $e->faultcode);
 
        print "\nString : ";
        print_r( $e->faultstring);
 
        print "\n ";

}
 
print_r($results);
 
?>


and this results are 

X-Powered-By: PHP/5.1.2
Content-type: text/html
 
An exception occurred!
Code : HTTP
String : Error Fetching http headers

I've included the "allow_self_signed" as the server certificate is signed by a CA I rolled myself. 

I've been watching Apache's logs on the server side, and I see 

==> /var/log/apache2/ssl_request_log <==
[13/Apr/2006:18:33:51 +0100] xxx.xxx.xxx.xxx TLSv1 DHE-RSA-AES256-SHA "GET /adabas/Employees?WSDL HTTP/1.0" 9665 "-" "-"
[13/Apr/2006:18:33:51 +0100] xxx.xxx.xxx.xxx - - "GET /" 992 "-" "-"

What is that second "GET" doing? I would of assumed that I would of seen a "GET" ( for WSDL) followed by a "POST" ( as the method is called) ?

I have to admit I was just introduced to PHP yesterday, so any help would be greatly appreciated!

Cheers,
Brian
 [2006-04-18 11:23 UTC] Brian dot Reynolds at risaris dot com
No ... scratch this ... it is a bug in the WSDL (service endpoint was wrong). I've got this to work now.
 [2006-04-18 11:39 UTC] tony2001@php.net
No bug -> bogus.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 19 12:01:26 2019 UTC