php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36373 Configure doesn't accept /usr/lib64
Submitted: 2006-02-12 23:25 UTC Modified: 2006-02-12 23:47 UTC
From: jaitropfaim at hotmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.4.2 OS: SuSE Linux 9.3 x64
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jaitropfaim at hotmail dot com
New email:
PHP Version: OS:

 

 [2006-02-12 23:25 UTC] jaitropfaim at hotmail dot com
Description:
------------
Hi,

i've downloaded php5 and php4...
PHP5 runs throuhg the configure and compiles perfectly on SuSE 9.3 x64...

However php4 configure doesn't LOOK IN THE RIGHT PLACE for my libaries ( /usr/lib64 ). "I.e. configure: error: Cannot find OpenSSL's libraries".

--libdir= doesn't help.
configure script doesn't find jpeg, png, ssl libaries...
( because they are all under /usr/lib64 )

Can you help me? we can't live without php4 on our new server.

Reproduce code:
---------------
./configure --enable-force-cgi-redirect --without-mm --enable-fastcgi --prefix=/srv/fastcgi/php-4.4.2 --libdir=/lib64 --with-openssl --with-gd --with-jpeg-dir --with-png-dir


Expected result:
----------------
configure should work on suse 9.3 x64

Actual result:
--------------
configure doesn't find the libaries and .h files and so on...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-12 23:37 UTC] tony2001@php.net
Support for 64bit OSes in ./configure has been added in 5.1 and it won't be backported.
With --libdir option you supposed to set where to PUT the libraries, so no, it's not what you want. See --with-libdir in 5.1.
 [2006-02-12 23:47 UTC] derick@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 23:05:54 2022 UTC