php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36217 with postgres 8.1, pg_escape_bytea escapes ' as '' and unescape leaves them ''
Submitted: 2006-01-30 21:30 UTC Modified: 2006-01-31 00:05 UTC
From: dabicho2001 at yahoo dot com dot mx Assigned:
Status: Not a bug Package: PostgreSQL related
PHP Version: 4.4.2 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dabicho2001 at yahoo dot com dot mx
New email:
PHP Version: OS:

 

 [2006-01-30 21:30 UTC] dabicho2001 at yahoo dot com dot mx
Description:
------------
pg_escape_bytea will escape a single quote as ''
i.e.
$a = "'";
$a = pg_escape_bytea($a);

$a now contains "''"

pg_unescape_bytea will leave them unmodified.
i.a.
$a = pg_unescape_bytea($a);

$a still contains "''"

apache's mod_php is 4.4.0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-30 21:48 UTC] tony2001@php.net
pg_escape_bytea() is just a wrapper for PQescapeBytea() function from Postgresql.
If you think it doesn't work properly - please report it to PG developers.
 [2006-01-30 23:54 UTC] dabicho2001 at yahoo dot com dot mx
silly me.
not a bug, just missinterpretation on my part.
 [2006-01-31 00:05 UTC] johannes@php.net
no bug -> bogus  
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jun 19 14:01:31 2024 UTC