php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #36194 Should support ldap_extended_operation(_s)
Submitted: 2006-01-28 21:22 UTC Modified: 2017-09-27 15:21 UTC
Votes:5
Avg. Score:5.0 ± 0.0
Reproduced:5 of 5 (100.0%)
Same Version:3 (60.0%)
Same OS:2 (40.0%)
From: jeff at coherentnetworksolutions dot com Assigned: heiglandreas (profile)
Status: Closed Package: LDAP related
PHP Version: 5.1.2 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jeff at coherentnetworksolutions dot com
New email:
PHP Version: OS:

 

 [2006-01-28 21:22 UTC] jeff at coherentnetworksolutions dot com
Description:
------------
PHP should support ldap_extended_operation/ldap_extended_operation_s . Note that both (at least) the OpenLDAP and Mozilla libraries have the same prototypes.


Patches

ldap-ctrl-exop56.patch-manu_at_netbsd_dot_org (last revision 2015-09-28 15:46 UTC by manu at netbsd dot org)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-21 21:34 UTC] jani@php.net
-Package: Feature/Change Request +Package: LDAP related
 [2017-01-09 16:43 UTC] heiglandreas@php.net
-Status: Open +Status: Feedback
 [2017-01-09 16:43 UTC] heiglandreas@php.net
This issue is open since more than 10 years and targets an unsupported version of PHP. Would you care to update the patch to match against a recent version of ldap.c? Or even better create a PullRequest against https://github.com/php/php-src?

Otherwise we'll close this issue within the next 2 months.
 [2017-01-10 08:00 UTC] heiglandreas@php.net
-Assigned To: +Assigned To: heiglandreas
 [2017-01-22 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2017-09-27 15:21 UTC] mcmic@php.net
-Status: No Feedback +Status: Closed
 [2017-09-27 15:21 UTC] mcmic@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

Support for extended operations have been added and will be available in PHP 7.2
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 04:05:54 2022 UTC