php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36101 file rwx
Submitted: 2006-01-20 14:22 UTC Modified: 2006-01-20 14:32 UTC
From: jackkempes at hotmail dot com Assigned:
Status: Not a bug Package: *Directory/Filesystem functions
PHP Version: 5.1.2 OS: 2.6.12-1.1456_FC4smp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jackkempes at hotmail dot com
New email:
PHP Version: OS:

 

 [2006-01-20 14:22 UTC] jackkempes at hotmail dot com
Description:
------------
copy, chmod , fopen will not work !

Reproduce code:
---------------
<?php
$filename='/filet/possu.txt';
if (is_writable($filename)  &&  is_readable($filename) && is_executable($filename) ) {
   echo 'kirjoitus,luku ja suoritus';
$fp=fopen("$filename","w");
fwrite($fp,"paskajuttu");
fclose($fp);
}
 else {
   echo 'ei voi kirjoittaa';
}
?>

Expected result:
----------------
kirjoitus,luku ja suoritus
Warning: fopen(/filet/possu.txt) [function.fopen]: failed to open stream: Permission denied in /var/www/html/aja.php on line 5

Warning: fwrite(): supplied argument is not a valid stream resource in /var/www/html/aja.php on line 6

Warning: fclose(): supplied argument is not a valid stream resource in /var/www/html/aja.php on line 7


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-20 14:31 UTC] tony2001@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2006-01-20 14:32 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 07:05:44 2022 UTC