php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36100 php-gtk-1.0.2 load error: "undefined symbol: gtk_shpaned_new"
Submitted: 2006-01-20 12:56 UTC Modified: 2006-01-20 23:53 UTC
From: jakub at gentoo dot org Assigned:
Status: Closed Package: PHP-GTK related
PHP Version: 1.0.0 (php 4.4.2) OS: Gentoo Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jakub at gentoo dot org
New email:
PHP Version: OS:

 

 [2006-01-20 12:56 UTC] jakub at gentoo dot org
Description:
------------
Trying to load php-gtk extension produces fatal error.


Reproduce code:
---------------
See http://bugs.gentoo.org/show_bug.cgi?id=90570 for the original bug report, also the issue and fix is noted by a user in http://gtk.php.net/manual/en/

The respective code hasn't been updated for a couple of years (http://cvs.php.net/viewcvs.cgi/php-gtk/main/php_gtk_ext.c.in?view=log)


Expected result:
----------------
Uhm, just work? ;)

Actual result:
--------------
"Warning: dl(): Unable to load dynamic library
'/usr/lib/php/extensions/no-debug-non-zts-20020429/php_gtk.so' -
/usr/lib/php/extensions/no-debug-non-zts-20020429/php_gtk.so: undefined symbol:
gtk_shpaned_new in..."


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-20 13:37 UTC] anant@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip

If you emerged PHP-Gtk from the portage tree, try building from source, or vice-versa.
 [2006-01-20 14:58 UTC] sfox@php.net
Should be fixed in CVS now. Please can you confirm this, as I have no way to test it.

Thanks!

 [2006-01-20 23:53 UTC] jakub at gentoo dot org
Thanks, works for me.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri May 24 14:01:26 2019 UTC