php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36068 at a "make test", php expects bison installed
Submitted: 2006-01-18 15:24 UTC Modified: 2006-01-18 18:59 UTC
From: php at rince dot de Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 5.1.2 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
42 - 4 = ?
Subscribe to this entry?

 
 [2006-01-18 15:24 UTC] php at rince dot de
Description:
------------
I just did a "make test" and somewhere it failed. As the testsuite tried to send the report to the php-group, it expected to have bison installed - which I hadn't at that time. configure didn't complain about a missing bison.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-18 15:30 UTC] tony2001@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2006-01-18 15:58 UTC] php at rince dot de
Situation:
Solaris 8 on Sparc. Fresh Download of php-sources, Version 5.1.2. unpack, "./configure --with-apxs2=/usr/local/apache-2.0.55/bin/apxs" results in a "Build complete."
After that I make a "make test", there are quite some tests and at one point the tests result apparently in an unexpected state. Then, the testsuite wants to report this and wants to use "bison" - which isn't installed usually on a Solaris machine. So there should be a check against bison in the configure-script (this was already a problem in php3, as I can see in the bug database).
 [2006-01-18 16:04 UTC] tony2001@php.net
Apparently you forgot to tell us what exactly the problem is.

>Then, the testsuite wants to report this and wants to use
> "bison" - which isn't installed usually on a Solaris machine.
And you know that because you see some error, right?
Or is it a secret?
 [2006-01-18 16:33 UTC] php at rince dot de
*sigh* since this machine has no internet-access I hoped it would be enough to tell that php expects bison but doesn't check wether it's there.

but here it is: I do the make test, there seems to be a problem:

----
XMLWriter: PI, Comment, CDATA [ext/xmlwriter/tests/00_009.phpt]
====================================================================

You may have found a problem in PHP.
We would like to send this report automatically to the
PHP QA team, to give us a better understanding of how 
the test cases are doing. If you don't want to send it
immediately, you can choose "s" to save the report to
a file that you can send us later.
Do you want to send this report now? [Yns]: y

Please enter your email address.
(Your address will be mangled so that it will not go out on any
mailinglist in plain txt):  [my email address]
sh: bison: not found
PHP Warning: PHP Startup: /: Unable to initialize module
[..]

If you look into "run-tests.php" line 717, it checks the version of bison if a test fails. And this check fails (of course) if bison is not installed. I don't know why php wants to have bison, but at least run-tests.php expects it.
 [2006-01-18 16:40 UTC] tony2001@php.net
So basically the problem could be solved by changing this line to `bison --version 2>/dev/null` ?
 [2006-01-18 18:47 UTC] php at rince dot de
To be honest, I have no idea, where and why php needs bison and/or yacc. configure is apparently checking for bison but it ignores it when it isn't installed and uses yacc instead. So I'd guess to ask one of the developers wether bison is needed or not.
 [2006-01-18 18:59 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 16:03:34 2022 UTC