php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36059 change in $_GET behavior
Submitted: 2006-01-17 20:52 UTC Modified: 2006-01-18 16:25 UTC
From: allen dot montz at ipayx dot com Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 5.1.2 OS: Linux ES 4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: allen dot montz at ipayx dot com
New email:
PHP Version: OS:

 

 [2006-01-17 20:52 UTC] allen dot montz at ipayx dot com
Description:
------------
Until PHP 5.0.5 with magic_quotes = OFF we preserved '+' characters in $_GET variables. Since PHP 5.1.1 it appears that $_GET is automatically urlencoded and in order to recover '+' we need to urldecode and ereg_replace(' ', '+', ...). If this is new standard behavior please provide me with reference on when this change has taken place and the reason behind it.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-17 21:03 UTC] sniper@php.net
No such change has been done. You're doing something wrong.
 [2006-01-18 15:48 UTC] allen dot montz at ipayx dot com
hmm ok. Maybe Apache changed.
 [2006-01-18 16:25 UTC] allen dot montz at ipayx dot com
One more question: are GET's automatically urlencoded or not? I'm not sure if our 'fix' is a good or bad idea, although it seems to work now.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Sep 28 08:03:36 2021 UTC