|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36048 ISAPI filter crash
Submitted: 2006-01-17 13:10 UTC Modified: 2006-01-28 01:00 UTC
Avg. Score:4.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:0 (0.0%)
From: piadoso at pobox dot sk Assigned:
Status: No Feedback Package: IIS related
PHP Version: 4.4.2 OS: Windows 2000 Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
Solve the problem:
45 - 27 = ?
Subscribe to this entry?

 [2006-01-17 13:10 UTC] piadoso at pobox dot sk
In new version php 4.4.2 crashing IIS. (error in ISAPI filter - event log is full by phpISAPI errors)
Preview version work OK.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-17 13:17 UTC]
We are aware of PHP's problems with stability under IIS and are working 
to rectify the problem. Unfortunatly your bug report does not contain any
extra useful information and we already have enough bug reports open about
this issue. If you can provide more detailed information such as a 
reproducable crash or a backtrace please do so and reopen this bug. 
Otherwise please keep trying new releases as we are working to resolve 
the problems on this platform
Thanks for your interest in PHP.

 [2006-01-17 13:17 UTC]
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2006-01-20 15:38 UTC] bw_fotoart at yahoo dot de
Hi everyone!

After a security Update from PHP 4.4.1 to 4.4.2 on a IIS Server version 6.0 on a Windows 2003 Server
everythink in Joomla works fine, only the Joomla Newsfeeds.(Joomla! 1.0.4 Stable [ Sundial ] 21-Nov-2005 10:00 UTC)

After Clicking on a Mainmen? Link (index.php?option=com_newsfeeds&task=view&feedid=1&Itemid=17) that opens a newsfeed nothing happends. (no Data in the Document)
I found in the Windows 2003 Server Application Logfiles follow error.

Faulting application w3wp.exe, version 6.0.3790.1830, faulting module php4isapi.dll, version, fault address 0x00002443.

This is not a Joomla Problem.
I Downgrade PHP back to 4.4.1 nowe everythink works fine.

 [2006-01-28 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2006-07-05 14:29 UTC] mark at xrar dot com dot au
I can confirm I was having a similar problem (same error message) with a different PHP application on a IIS 6 box. Applying the latest CVS has resolved the problem
 [2006-08-03 14:28 UTC] scott at naimanclarke dot com dot au
I was having the problem with 4.4.2 and found this bug. Just downloaded and installed 4.4.3 and I am having the same problem. If I use php.exe instead I get a headers misbehaving error instead of a crash. This error only occurs with certain files (I think it is when file(), curl() and fopen() commands are run). It could also be related to directory permissions, although I have tried setting all of them to rx IUSR_* but this has no effect.
 [2006-08-03 15:22 UTC] scott at naimanclarke dot com dot au
This problem was traced to conflicting dll versions installed on the server. Namely the PHP related dll's in C:\Windows\System32 were not from the same release as those in C:\PHP.
 [2006-08-24 14:32 UTC] wizadsl at bellsouth dot net
In my case, the IIS worker process crash was the result of the bug in version 4.4.1 that crashed PHP if a url was used within the fopen or require function, for example, require("") would cause the error as described. This specific cause was fixed in 4.4.3, see PHP bug #36017
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 15 17:01:32 2024 UTC