php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #36009 preg_replace wrong parametre count
Submitted: 2006-01-14 13:17 UTC Modified: 2006-01-14 14:17 UTC
From: telnes at graffline dot org Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: php5.1 OS: XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: telnes at graffline dot org
New email:
PHP Version: OS:

 

 [2006-01-14 13:17 UTC] telnes at graffline dot org
Description:
------------
parametre count didn't work well

Reproduce code:
---------------
the doc code

<?php
$count = 0;

echo preg_replace(array('/\d/', '/\s/'), '*', 'xp 4 to', -1 , $count);
echo $count; //3
?> 



Expected result:
----------------
i expect the doc result 3 :)

Actual result:
--------------
actualy the result I have is

Warning: Wrong parameter count for preg_replace() in e:\...php on line x 

it meen that the $count variable is to much I think !
maby the probleme came because i don't upgrade my php version well.(php4->php5)

other question :

why the php.net don'give the same synthaxe for the preg_replace than nexen.net

PHP.NET =>
mixed preg_replace ( mixed pattern, mixed replacement, mixed subject [, int limit [, int &count]] )


NENXEN.NET =>
mixed  preg_replace ( mixed   pattern , mixed   replacement , mixed   subject , int   limit , int   count ) 


int &count != int count
    ^
(using reference ???)

thanks telnes




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-14 13:19 UTC] telnes at graffline dot org
my php version PHP 5.1
 [2006-01-14 13:38 UTC] tony2001@php.net
There is no such version as 5.1.
We know nothing about mexen.net (what was it name again?), PHP.net is the only site where you should look for the docs.
And yes, your code works fine.
 [2006-01-14 14:12 UTC] telnes at graffline dot org
the probleme came on the update on php4 to php5 on my computer I think !

bug close !
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 31 02:01:23 2021 UTC