php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3600 .php3 filetype not recognized
Submitted: 2000-02-23 22:18 UTC Modified: 2002-09-30 20:14 UTC
From: sommer at mugs dot net Assigned:
Status: Not a bug Package: Installation problem
PHP Version: 3.0.14 OS: Linux (2.2.1 kernel, custom buil
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: sommer at mugs dot net
New email:
PHP Version: OS:

 

 [2000-02-23 22:18 UTC] sommer at mugs dot net
Using apache 1.3.11, built from the tarball.

php module shows in httpd -l:
Compiled-in modules:
http_core.c,  mod_env.c, mod_log_config.c, mod_mime.c, mod_negotiation.c, mod_status.c, mod_include.c, mod_autoindex.c, mod_dir.c, mod_cgi.c, mod_asis.c, mod_imap.c, mod_actions.c, mod_userdir.c, mod_alias.c, mod_access.c, mod_auth.c, mod_setenvif.c ,mod_php3.c

The AddType is listed in the correct httpd.conf file:
AddType application-x-httpd-php3 .php3
AddType application-x-httpd-php3 .php
AddType application/x-httpd-php3 .phtml
AddType application/x-httpd-php3-source .phps

Apache error log says:
[Wed Feb 23 10:38:57 2000] [warn] mod_mime: analyze_ct: cannot get media type fr
om 'application-x-httpd-php3'

Apache's server-status directive says PHP is installed, too:
Server Version: Apache/1.3.11 (Unix) PHP/3.0.14
Server Built: Feb 23 2000 09:46:22

Yet it still asks me if I want to download the file (see: http://www.infonation.net/info.php3)

I'm stumped.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-30 20:07 UTC] hholzgra@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.

most likely due to module loading order ...
 [2002-09-30 20:14 UTC] sommer at mugs dot net
Um, OK. Only took 2.5 years to come back with that. Long since taken care of that issue. :)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 28 12:03:36 2021 UTC