php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35934 mysql_fetch_field makes apache child process segfault
Submitted: 2006-01-08 22:48 UTC Modified: 2006-01-08 23:32 UTC
From: jb-boin at ownz dot us Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5CVS-2006-01-08 (snap) OS: Debian Woody Unstable
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jb-boin at ownz dot us
New email:
PHP Version: OS:

 

 [2006-01-08 22:48 UTC] jb-boin at ownz dot us
Description:
------------
The Apache child process are segfaulting when using mysql_fetch_field.
I'm using Apache 2.2+Php5.1x snap 07-01-06+Mysql 5.0.18
I also tried with Apache 2.0x, php5.1.1 and mysql 4.1.15, i have the same problem since about one month, maybe a bit more.

Reproduce code:
---------------
Looking to a table in phpmyadmin (sql.php which use mysql.dbi.lib.php to invoke the mysql_fetch_field), I tried 2 or 3 versions of phpmyadmin without success.

Expected result:
----------------
See the page insteam of a blank one

Actual result:
--------------
(gdb) bt
#0  0xb7dcfc9b in strlen () from /lib/tls/libc.so.6
#1  0xb7bd0f0f in add_property_string_ex (arg=0x84866a4, key=0xb7c8389e "def",
    key_len=4, str=0x2 <Address 0x2 out of bounds>, duplicate=1)
    at /root/sources/php-5.1.1/Zend/zend_API.c:1264
#2  0xb7a95d04 in zif_mysql_fetch_field (ht=2, return_value=0x84866a4,
    return_value_ptr=0x0, this_ptr=0x0, return_value_used=1)
    at /root/sources/php-5.1.1/ext/mysql/php_mysql.c:2266
#3  0xb7bf2767 in zend_do_fcall_common_helper_SPEC (execute_data=0xbff874c0)
    at zend_vm_execute.h:188
#4  0xb7bf1f19 in execute (op_array=0x8330a18) at zend_vm_execute.h:88
#5  0xb7bf212d in zend_do_fcall_common_helper_SPEC (execute_data=0xbff8c3b0)
    at zend_vm_execute.h:222
#6  0xb7bf1f19 in execute (op_array=0x8279234) at zend_vm_execute.h:88
#7  0xb7bcfbdc in zend_execute_scripts (type=8, retval=Variable "retval" is not available.
)
    at /root/sources/php-5.1.1/Zend/zend.c:1090
#8  0xb7b98c2b in php_execute_script (primary_file=0xbff8e6e4)
    at /root/sources/php-5.1.1/main/main.c:1704
#9  0xb7c5ae9a in php_handler (r=0x826bc10)
    at /root/sources/php-5.1.1/sapi/apache2handler/sapi_apache2.c:584
#10 0x080730a6 in ap_run_handler (r=0x826bc10) at config.c:157
#11 0x080734a2 in ap_invoke_handler (r=0x826bc10) at config.c:371
#12 0x08089e9d in ap_process_request (r=0x826bc10) at http_request.c:258
#13 0x08087789 in ap_process_http_connection (c=0x825ab20) at http_core.c:171
---Type <return> to continue, or q <return> to quit---
#14 0x080791c6 in ap_run_process_connection (c=0x825ab20) at connection.c:43
#15 0x080a3201 in child_main (child_num_arg=Variable "child_num_arg" is not avai lable.
) at prefork.c:640
#16 0x080a3442 in make_child (s=Variable "s" is not available.
) at prefork.c:736
#17 0x080a34ea in startup_children (number_to_start=5) at prefork.c:754
#18 0x080a3d38 in ap_mpm_run (_pconf=0x80f00a8, plog=0x812e1a0, s=0x80f52c0)
    at prefork.c:975
#19 0x080615ef in main (argc=1, argv=0xbff8eb24) at main.c:712
(gdb) frame 4
#4  0xb7bf1f19 in execute (op_array=0x8330a18) at zend_vm_execute.h:88
88                      if (EX(opline)->handler(&execute_data TSRMLS_CC) > 0) {
(gdb) print (char *)(executor_globals.function_state_ptr->function)->common.func tion_name
$1 = 0xb7c73d2f "mysql_fetch_field"
(gdb) print (char *)executor_globals.active_op_array->function_name
$2 = 0x833c41c "PMA_DBI_get_fields_meta"
(gdb) print (char *)executor_globals.active_op_array->filename
$3 = 0x833a5ac "/home/web/phpMyAdmin-2.6.4-pl4/libraries/dbi/mysql.dbi.lib.php"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-08 22:52 UTC] tony2001@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

See bug #35753.
 [2006-01-08 23:32 UTC] jb-boin at ownz dot us
Sorry for this.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 12:01:29 2024 UTC